Magento Expert Forum - Improve your Magento experience

Results 1 to 1 of 1

Third Party extension messing with linnworks API via SOAP

  1. #1
    New member
    Join Date
    Jul 2018
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Third Party extension messing with linnworks API via SOAP

    Hello, I hope someone can help me. I'm not very knowledgeable in this department. I had someone to develop and install a third party extension into my site to allow customers to personalise a product with text. When the extension is enabled i receive errors with my Linnworks order management with regards to my inventory sync. Linnworks attempts to change the stock level in Magento 1.9 but it throws back an error. The issue is only when the product is enabled, can anyone please help to shed some more light on what the issue could be.



    Here is the full API call and response. I have change the sitename and deleted some of the numbers in case they are a key of some kind -



    REQUEST

    Code:
    POST http://www.mywebsite.co.uk/index.php/api/v2_soap/ HTTP/1.1
    User-Agent: Linnsystems
    VsDebuggerCausalityData: uIDPo68QtFPs/eJpoVYAAAAA/J4O4SIRFL7vc2mEnU431ZAueBPVqzuWsUACQAA
    Content-Type: text/xml; charset=utf-8
    SOAPAction: ""
    Host: www.mywebsite.co.uk
    Content-Length: 628
    Expect: 100-continue
    
    <?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><catalogProductUpdateRequestParam xmlns="urn:Magento"><sessionId xmlns="">ed6f9b178cf42ee0426690</sessionId><productId xmlns="">802</productId><productData xmlns=""><stock_data><qty>10</qty><is_in_stock>1</is_in_stock><manage_stock>1</manage_stock></stock_data></productData><store xmlns="" /><identifierType xmlns="">id</identifierType></catalogProductUpdateRequestParam></soap:Body></soap:Envelope>

    ===RESPONSE==

    Code:
    HTTP/1.1 500 Internal Server Error
    Set-Cookie: PHPSESSID=28hh90bp49o7nj0; expires=Mon, 30-Jul-2018 16:56:59 GMT; Max-Age=7200; path=/; domain=mywebsite.co.uk
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Content-Type: text/xml; charset=utf-8
    Content-Length: 308
    Date: Mon, 30 Jul 2018 14:58:23 GMT
    Accept-Ranges: bytes
    Server: LiteSpeed
    Connection: Keep-Alive
    
    <?xml version="1.0" encoding="UTF-8"?>
    <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body><SOAP-ENV:Fault><faultcode>SOAP-ENV:Server</faultcode><faultstring>Call to a member function getId() on null</faultstring></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>

    View more threads in the same category:

    Last edited by mattee77; 31-07-2018 at 03:35 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •