Magento Expert Forum - Improve your Magento experience

Results 1 to 3 of 3

udating through magento connect

  1. #1
    New member
    Join Date
    Nov 2014
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default udating through magento connect

    Hey folks.

    i was trying to update magento 1.7.0.2 to 1.9.0.0 with magento connect. i have followed all the guides i can find on the subject but for some reason i keep getting the same error.
    yes i know alot will say now not to use magento connect, but from reading guides it dosnt seem to be a problem to do it that way.

    anyways this is what magento connect spits out at me when trying to update.

    Checking dependencies of packages
    Already installed: community/Lib_Js_Ext 1.7.0.0, skipping
    Already installed: community/Lib_LinLibertineFont 2.8.14.1, skipping
    Already installed: community/Lib_Js_TinyMCE 3.4.7.1, skipping
    Already installed: community/Lib_Js_Calendar 1.51.1.1, skipping
    Already installed: community/Lib_Phpseclib 1.5.0.0, skipping
    Already installed: community/Mage_Locale_de_DE 1.9.0.0, skipping
    Already installed: community/Mage_Locale_es_ES 1.9.0.0, skipping
    Already installed: community/Mage_Locale_fr_FR 1.9.0.0, skipping
    Already installed: community/Mage_Locale_nl_NL 1.9.0.0, skipping
    Already installed: community/Mage_Locale_pt_BR 1.9.0.0, skipping
    Already installed: community/Mage_Locale_zh_CN 1.9.0.0, skipping
    Already installed: community/Lib_Mage 1.8.0.0, skipping
    Already installed: community/Lib_Magento 1.9.0.0, skipping
    Already installed: community/Lib_Credis 1.8.0.0, skipping
    Already installed: community/Lib_Js_Prototype 1.7.0.0.5, skipping

    CONNECT ERROR: Package community/Interface_Adminhtml_Default 1.9.0.0 conflicts with: community/Mage_All_Latest 1.7.0.2
    Package community/Mage_Core_Adminhtml 1.9.0.0 conflicts with: community/Interface_Adminhtml_Default 1.7.0.1, community/Mage_All_Latest 1.7.0.2, community/Mage_Compiler 1.7.0.0
    Package community/Mage_Core_Modules 1.9.0.1 conflicts with: community/Interface_Frontend_Base_Default 1.7.0.1, community/Interface_Frontend_Default 1.7.0.0, community/Interface_Install_Default 1.7.0.0, community/Mage_All_Latest 1.7.0.2, community/Mage_Centinel 1.7.0.0, community/Mage_Compiler 1.7.0.0, community/Mage_Core_Adminhtml 1.7.0.1, community/Magento_Mobile 1.7.0.1.22.1, community/Phoenix_Moneybookers 1.3.1
    Package community/Lib_Varien 1.9.0.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Lib_Google_Checkout 1.8.1.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Lib_Js_Mage 1.9.0.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Mage_Locale_en_US 1.9.0.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Lib_ZF 1.12.3.0 conflicts with: community/Lib_Varien 1.7.0.0
    Package community/Lib_ZF_Locale 1.12.3.0 conflicts with: community/Lib_ZF 1.11.1.0

    Checking dependencies of packages
    Already installed: community/Lib_Js_Calendar 1.51.1.1, skipping
    Already installed: community/Lib_Phpseclib 1.5.0.0, skipping
    Already installed: community/Mage_Locale_de_DE 1.9.0.0, skipping
    Already installed: community/Mage_Locale_es_ES 1.9.0.0, skipping
    Already installed: community/Mage_Locale_fr_FR 1.9.0.0, skipping
    Already installed: community/Mage_Locale_nl_NL 1.9.0.0, skipping
    Already installed: community/Mage_Locale_pt_BR 1.9.0.0, skipping
    Already installed: community/Mage_Locale_zh_CN 1.9.0.0, skipping
    Already installed: community/Lib_Mage 1.8.0.0, skipping
    Already installed: community/Lib_Magento 1.9.0.0, skipping
    Already installed: community/Lib_Credis 1.8.0.0, skipping
    Already installed: community/Lib_Js_Prototype 1.7.0.0.5, skipping

    CONNECT ERROR: Package community/Interface_Frontend_Default 1.9.0.0 conflicts with: community/Mage_All_Latest 1.7.0.2
    Package community/Mage_Core_Modules 1.9.0.1 conflicts with: community/Interface_Frontend_Base_Default 1.7.0.1, community/Interface_Frontend_Default 1.7.0.0, community/Interface_Install_Default 1.7.0.0, community/Mage_All_Latest 1.7.0.2, community/Mage_Centinel 1.7.0.0, community/Mage_Compiler 1.7.0.0, community/Mage_Core_Adminhtml 1.7.0.1, community/Magento_Mobile 1.7.0.1.22.1, community/Phoenix_Moneybookers 1.3.1
    Package community/Lib_Varien 1.9.0.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Lib_Google_Checkout 1.8.1.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Lib_Js_Mage 1.9.0.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Mage_Locale_en_US 1.9.0.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Lib_ZF 1.12.3.0 conflicts with: community/Lib_Varien 1.7.0.0
    Package community/Lib_ZF_Locale 1.12.3.0 conflicts with: community/Lib_ZF 1.11.1.0

    Checking dependencies of packages
    Already installed: community/Lib_Js_Calendar 1.51.1.1, skipping
    Already installed: community/Lib_Phpseclib 1.5.0.0, skipping
    Already installed: community/Mage_Locale_de_DE 1.9.0.0, skipping
    Already installed: community/Mage_Locale_es_ES 1.9.0.0, skipping
    Already installed: community/Mage_Locale_fr_FR 1.9.0.0, skipping
    Already installed: community/Mage_Locale_nl_NL 1.9.0.0, skipping
    Already installed: community/Mage_Locale_pt_BR 1.9.0.0, skipping
    Already installed: community/Mage_Locale_zh_CN 1.9.0.0, skipping
    Already installed: community/Lib_Mage 1.8.0.0, skipping
    Already installed: community/Lib_Magento 1.9.0.0, skipping
    Already installed: community/Lib_Credis 1.8.0.0, skipping
    Already installed: community/Lib_Js_Prototype 1.7.0.0.5, skipping

    CONNECT ERROR: Package community/Interface_Install_Default 1.9.0.0 conflicts with: community/Mage_All_Latest 1.7.0.2
    Package community/Mage_Core_Modules 1.9.0.1 conflicts with: community/Interface_Frontend_Base_Default 1.7.0.1, community/Interface_Frontend_Default 1.7.0.0, community/Interface_Install_Default 1.7.0.0, community/Mage_All_Latest 1.7.0.2, community/Mage_Centinel 1.7.0.0, community/Mage_Compiler 1.7.0.0, community/Mage_Core_Adminhtml 1.7.0.1, community/Magento_Mobile 1.7.0.1.22.1, community/Phoenix_Moneybookers 1.3.1
    Package community/Lib_Varien 1.9.0.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Lib_Google_Checkout 1.8.1.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Lib_Js_Mage 1.9.0.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Mage_Locale_en_US 1.9.0.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Lib_ZF 1.12.3.0 conflicts with: community/Lib_Varien 1.7.0.0
    Package community/Lib_ZF_Locale 1.12.3.0 conflicts with: community/Lib_ZF 1.11.1.0

    Checking dependencies of packages
    Already installed: community/Lib_Js_Ext 1.7.0.0, skipping
    Already installed: community/Lib_LinLibertineFont 2.8.14.1, skipping
    Already installed: community/Lib_Js_TinyMCE 3.4.7.1, skipping
    Already installed: community/Lib_Js_Calendar 1.51.1.1, skipping
    Already installed: community/Lib_Phpseclib 1.5.0.0, skipping
    Already installed: community/Mage_Locale_de_DE 1.9.0.0, skipping
    Already installed: community/Mage_Locale_es_ES 1.9.0.0, skipping
    Already installed: community/Mage_Locale_fr_FR 1.9.0.0, skipping
    Already installed: community/Mage_Locale_nl_NL 1.9.0.0, skipping
    Already installed: community/Mage_Locale_pt_BR 1.9.0.0, skipping
    Already installed: community/Mage_Locale_zh_CN 1.9.0.0, skipping
    Already installed: community/Lib_Mage 1.8.0.0, skipping
    Already installed: community/Lib_Magento 1.9.0.0, skipping
    Already installed: community/Lib_Credis 1.8.0.0, skipping
    Already installed: community/Lib_Js_Prototype 1.7.0.0.5, skipping

    CONNECT ERROR: Package community/Mage_Core_Adminhtml 1.9.0.0 conflicts with: community/Interface_Adminhtml_Default 1.7.0.1, community/Mage_All_Latest 1.7.0.2, community/Mage_Compiler 1.7.0.0
    Package community/Mage_Core_Modules 1.9.0.1 conflicts with: community/Interface_Frontend_Base_Default 1.7.0.1, community/Interface_Frontend_Default 1.7.0.0, community/Interface_Install_Default 1.7.0.0, community/Mage_All_Latest 1.7.0.2, community/Mage_Centinel 1.7.0.0, community/Mage_Compiler 1.7.0.0, community/Mage_Core_Adminhtml 1.7.0.1, community/Magento_Mobile 1.7.0.1.22.1, community/Phoenix_Moneybookers 1.3.1
    Package community/Lib_Varien 1.9.0.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Lib_Google_Checkout 1.8.1.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Lib_Js_Mage 1.9.0.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Mage_Locale_en_US 1.9.0.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Lib_ZF 1.12.3.0 conflicts with: community/Lib_Varien 1.7.0.0
    Package community/Lib_ZF_Locale 1.12.3.0 conflicts with: community/Lib_ZF 1.11.1.0

    Checking dependencies of packages
    Already installed: community/Lib_Js_Calendar 1.51.1.1, skipping
    Already installed: community/Lib_Phpseclib 1.5.0.0, skipping
    Already installed: community/Mage_Locale_de_DE 1.9.0.0, skipping
    Already installed: community/Mage_Locale_es_ES 1.9.0.0, skipping
    Already installed: community/Mage_Locale_fr_FR 1.9.0.0, skipping
    Already installed: community/Mage_Locale_nl_NL 1.9.0.0, skipping
    Already installed: community/Mage_Locale_pt_BR 1.9.0.0, skipping
    Already installed: community/Mage_Locale_zh_CN 1.9.0.0, skipping
    Already installed: community/Lib_Mage 1.8.0.0, skipping
    Already installed: community/Lib_Magento 1.9.0.0, skipping
    Already installed: community/Lib_Credis 1.8.0.0, skipping
    Already installed: community/Lib_Js_Prototype 1.7.0.0.5, skipping

    CONNECT ERROR: Package community/Mage_Core_Modules 1.9.0.1 conflicts with: community/Interface_Frontend_Base_Default 1.7.0.1, community/Interface_Frontend_Default 1.7.0.0, community/Interface_Install_Default 1.7.0.0, community/Mage_All_Latest 1.7.0.2, community/Mage_Centinel 1.7.0.0, community/Mage_Compiler 1.7.0.0, community/Mage_Core_Adminhtml 1.7.0.1, community/Magento_Mobile 1.7.0.1.22.1, community/Phoenix_Moneybookers 1.3.1
    Package community/Lib_Varien 1.9.0.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Lib_Google_Checkout 1.8.1.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Lib_Js_Mage 1.9.0.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Mage_Locale_en_US 1.9.0.0 conflicts with: community/Mage_Core_Modules 1.7.0.2
    Package community/Lib_ZF 1.12.3.0 conflicts with: community/Lib_Varien 1.7.0.0
    Package community/Lib_ZF_Locale 1.12.3.0 conflicts with: community/Lib_ZF 1.11.1.0


    any help is greatly appreciated

    View more threads in the same category:


  2. #2
    Junior Member wphd's Avatar
    Join Date
    May 2013
    Posts
    22
    Thanks
    1
    Thanked 2 Times in 2 Posts

    Default

    You shouldn't update via magento connect. I see it can happen a lot of risk. I usually do these steps

    - Use the old database => Install new magento version on it
    - Move one by one magento extensions from old the new verson (maybe some need to upgrade manually what can't be upgraded via magento connect)
    - New magento site will have all old products/orders and keep new upgrade extensions

    Hope it help.

  3. #3
    New member
    Join Date
    Nov 2014
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    okay so as long as i use the old database all old orders and products etc will still be there?

    i will try this instead then, thank you very much

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •