Magento Expert Forum - Improve your Magento experience

Results 1 to 3 of 3

Issues with Shipping module not retaining the fields entered

  1. #1
    New member
    Join Date
    Nov 2013
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Issues with Shipping module not retaining the fields entered

    I’m facing an issue with shipping module on one of my clients website. Here is the link of the website below: www.italianbicycles.com.au

    The issue is while we are using the website on mobile device. After any product is added to the cart & while on the My cart page, scroll down to see the shipping calculations box.

    When I select the country, write the name of the state & enter the pin-code - Pressing the “Get a Quote” button refreshes the page & shows the calculations. Then when I click on the “Update Total” button, after clicking the radio button for the toll ipec shipping cost, the page again refreshes & shows the added total in the Grand total above.

    ISSUE:

    Now the issue is that my client wants the first field of the Shipping calculations i.e. the country to show “Please select your country”. When I do that, when on the first step if I select the country, write the state name & enter the pin-code, as soon as I press the “Get a Quote” button, the page refreshes and do not retain the fields that were selected by the user before.

    If anyone can tell me the solution for this from the expert members of the community, it will be very helpful.

    Please let me know if anyone else has faced this problem & possible solution for this.

    Thank you,
    Swapnil Samfrancisco. Name:  issue_here.jpg
Views: 8
Size:  53.6 KB

    View more threads in the same category:


  2. #2
    Moderator shunavi's Avatar
    Join Date
    Mar 2013
    Posts
    130
    Thanks
    10
    Thanked 29 Times in 15 Posts

    Default

    I think the problem come from the theme, if you switch to the default theme I believe it will work well. If yes, the problem come from the theme template files what didn't get back the post data to form

  3. #3
    New member
    Join Date
    Nov 2013
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thank you for your reply.

    But actually I am using Mobile theme for Iphone. Problem occur while I am going to add product on the my cart page. If I select the country, write the state name & enter the pin-code, as soon as I press the “Get a Quote” button, the page refreshes and do not retain the fields that were selected by the user before.
    Although the results for the Get a quote are right BUT due to the fields being blank/default, it creates confusion.

    I have use default theme but problem remain there.

    You can review this on your iPhone with the link www.italianbicycles.com.au

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •