Magento Expert Forum - Improve your Magento experience

Results 1 to 2 of 2

Exceeds MaxRequestLen (16777216) mod_fcgid unable to upload large files

  1. #1
    Administrator david's Avatar
    Join Date
    Nov 2012
    Posts
    261
    Thanks
    22
    Thanked 42 Times in 34 Posts

    Thumbs up Exceeds MaxRequestLen (16777216) mod_fcgid unable to upload large files

    Our forum magentoexpertforum.com meet the problem with images upload these days. The problem is we want to get the forum speed fast as much as possible so that we use CDN and server side fast-cgi without mod_rewrite activated.

    One of the problems of fast-cgi is the default upload file is too small and we meet the problem when upload file all of time. we already fix it with this way and now share with you guys.

    Its in a 2 locations Edit the Apache2, virtualhost config and the virtual host setup files.

    edit these 2 files:

    Code:
    /etc/apache2/mods-available/fcgid.conf
    /var/www/vhosts/your_domain_name_here/conf/last_httpd_ip_default.include
    and add these lines:

    HTML Code:
    <IfModule mod_fcgid.c>
      MaxRequestLen 20971520
      FcgidMaxRequestLen 20971520
    </IfModule>
    If you have other config info in your module, leave it. Ive added 20971520 bytes which is 10Mb.

    Apparently fcgid settings ARE ALSO in your virtual hosts file here:

    Code:
    /usr/local/psa/admin/conf/templates/default/domain/domainVirtualHost.php
    PHP Code:
    <?php 
    if
     
    (
    $VAR->domain->physicalHosting->php || $VAR->domain->physicalHosting->phpHandlerType == 
    'fastcgi'
    ): ?>
    <IfModule mod_fcgid.c>
        
    FcgidInitialEnv PP_CUSTOM_PHP_INI <?php 
    echo
     
    $VAR->domain->physicalHosting->vhostDir ?>
    /etc/php
    .ini
        
    FcgidMaxRequestLen 20971520 
    </IfModule>
    <?php endif; ?>
    edit the FcgidMaxRequestLen value. Mine is 10Mb now.

    Lets reconfigure your domain


    Code:
    /usr/local/psa/admin/bin/httpdmng
    Code:
    --reconfigure-domain yourdomain.com
    Finally, I restarted PSA and Apache2

    Code:
    % service apache2 restart
    and

    Code:
    % service psa restart
    Go back to your web page and you should be able to upload large files now.

    mod_fcgid: HTTP request length (so far) exceeds MaxRequestLen

    mod_fcgid MaxRequestLen ubuntu 12

    View more threads in the same category:


  2. #2
    New member
    Join Date
    Jun 2021
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Forum is posting about the exceeding of maximum request and unable to upload the large files here in it. David is an administrator here and homeworkmarket.com reviews are posted in year 2012 with the codes and file of HTML, PHP and many others that are associated in it.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •