Magento Expert Forum - Improve your Magento experience

Results 1 to 4 of 4

Checkout Success Page Freeze

  1. #1
    New member
    Join Date
    Aug 2013
    Location
    Leicestershire, England
    Posts
    7
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Question Checkout Success Page Freeze

    To the point; We have the (Templates Master?) FireCheckout module installed which has been working adequately since launch roughly 5/6 months ago. We recently however have had a few customers saying that the checkout “locks” and when returning to continue the checkout they are being told that a duplicate order has already been placed. On “our” side we recieve only one order, the stock quantity reduces by 1 (or the correct amount ordered).

    On trying to recreate the issue I was able to place an order successfully BUT on the checkout/index/success page, where I am showed my order # etc, about 2-3 seconds after pageload the tab/page freezes/locks completely.

    so in essence; the order is created successfully and sent to all appropriate places, but the success page locks. I looked at the success.php page and it is relatively bare in that it shows, the text, retrieves the order # and displays, shows a button to “continue shopping” and then has some google sales conversion code at the bottom. I.E; nothing I (in my limited experience/knowledge) can see that would freeze a page.

    Even stranger is that the issue seemed to resolve itself the next morning.

    There was only one change made on the website just before it “broke” which was the change of some header links and the CSS file for our theme… nothing which would affect the checkout.

    Does anyone have any clues? The issue is not happening for now but it could certainly arise again and I’d like to know a potential fix.

    View more threads in the same category:


  2. #2
    Moderator speed2x's Avatar
    Join Date
    Mar 2013
    Location
    Hollywood, Florida, United States
    Posts
    91
    Thanks
    9
    Thanked 7 Times in 6 Posts

    Default

    I already met the problem same like you before but I am not sure it come from the same reason. My reason come from caching and indexing. So the solution is I clear all of files/folders in folder "var/" (var of magento root, not var of OS ). And then re-index all and delete all cache in back end again. It should work well then. Hope it help you.

  3. The Following User Says Thank You to speed2x For This Useful Post:

    ffdjames (13-08-2013)

  4. #3
    New member
    Join Date
    Aug 2013
    Location
    Leicestershire, England
    Posts
    7
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Default

    I'll have to test this, bit of a bugbear though since the issue is so intermittent.

    Maybe if this is the case I'll have to take a look at optimizing the cache and indexing somehow.

  5. #4
    Junior Member
    Join Date
    Jun 2014
    Posts
    93
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Default

    This is sounding good mate and it feels like the growth is going good for sure,Most of the times when its about moving ahead in to the correct direction we get to see things that are working and in the same way help us with understanding how it has worked so yeah this is the way how it is and surely it can be working.
    Whoever said money can't buy happiness simply didn't know where to go shopping. https://www.facebook.com/pages/Kod-w...18093881556423

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •